site statistics

Personal
Small Business
Commercial
Investing
Planning & Resources
Community Focus
About Us

The Heartbleed Bug

Earlier this week, the nation became aware of a critical vulnerability on websites and applications that use a particular version of what's called OpenSSL (Open source secure socket layer framework). The vulnerable version could expose your sensitive data to a remote attacker.

At Rockland Trust your security is our number one priority. We assure you that Rockland Trust does not use the OpenSSL version in question to encrypt your data. In addition to encryption, we use multiple other security layers to help ensure your protection. Please feel free to contact us if you have any additional questions.  


ABOUT SSL CERTIFICATES



For first time login instructions click here>>

Login To Online Banking

Enter Personal / Business User ID